Shapesynth AU - SOLVED

edited September 2020 in Bug Reports

Was trying out the new AU version of Shapesynth and noticed an issue. Sent the following to the dev:

Hi Erik - great update and glad to see AU. One tiny (I hope) issue. In NanoStudio 2 the NS2 mod wheel is controlling SS overall gain. So every time I change a patch I get no sound because the mod wheel default position is zero. By increasing the mod wheel to 100% I get the proper sound level. I’m not sure exactly how the mod wheel in NS2 is implemented because it seems to work differently with different apps. Maybe you can take a look at this when you get a chance? Thanks!


  • edited December 2019

    mod wheel simply sends CC1 ... modwheel is part of patch in NS so if you're browsing AU synth factory patches, Mod Wheel resets itself to default (zero) value when you change patch (which means it sends 0 to synth)

    Other daws are not doing this probably because they do not have build in patch librarian or (i guess) they do not store modwheel position in internsl patch database, so they send value of modwheel into synth only when wheel is tweaked

    i think mapping modwheel to volume makes not much sense, it's unwritten MIDI standard that modwheel should be mapped, unsurpridingly :), to some modulation with default zero value (eg. no mod)

  • I was thinking that in most cases it's the AU that is mapping Mod Wheel / CC1 to something other than the typical destination and nothing to do with NS2. That's why I wish apps followed MIDI standard for CC mapping but that got out of control long ago in iOS. I don't think a lot of devs were aware of (or cared about) the established MIDI standards.

  • In SS AUv3 parameters, Gain is set to CC1. Since CC’s were not enabled I didn’t think they would have any effect. I decided to change it anyway. I made it CC90 which is an undefined CC in the MIDI spec. Problem solved.

This discussion has been closed.